Bad performance

Hi

I bought the game today and realised my laptop is too weak to run it (Intel graphics). So I went to a local shop to pick up a power supply for my old desktop.

After hooking everything up and installing the game I'm faced with even worse performance than the Intel graphics.

The specs:
AMD A10-5800K
ATI 5870
8GB ram
SSD

Opening HWMonitor shows no GPU utilization and barely any CPU utilization.

Any suggestions?

Comments

  • Been trying to make the game run the past two days.... I'm giving up..

    On my desktop it wont let me change resolution and everything is so choppy its painful to watch.

    I took a gamble by buying a new power supply.. It was a gamble I lost.

    I'm utterly disappointed atm as I really wanted to try this game.
  • DireDire Canada, UO Napa Valley pre Tram, UO SP
    Maybe time to upgrade the whole thing?

  • Dire said:

    Maybe time to upgrade the whole thing?

    Perhaps. I ordered a Shadow PC yesterday. 15 days waiting time.
  • edited January 25
    Anders said:

    Dire said:

    Maybe time to upgrade the whole thing?

    Perhaps. I ordered a Shadow PC yesterday. 15 days waiting time.
    This will solve your issue. Mine works very well and has a ping of 7. You will still lag jump at server lines. No machine prevents that.
  • edited January 26
    Borrowed a GTX 970 today and it still would not run... Got impatient and bought a Dell G5 gaming laptop.
    About to install the game.
    If it still won't run, I've got 50 days to decide if I wanna keep the laptop or not.

    Returned the Dell G5 due to fan noise. Tried to run the game once again on my old desktop and now it Works... I've changed the compability settings to "Deactivate fullscreen optimization" and "run as administrator" - seems to work…
Sign In or Register to comment.