Download files are corrupt.

I've downloaded the game maybe 10 times now? On chrome and edge. Every time I download it and try to install it keeps coming up as having problems with bin 1 or bin 2. Any ideas on what to do?

Comments

  • When I try to download it from Edge it says the signature of LegendsOfAria-0.8.2.exe is corrupt or invalid.
  • SachaSacha [Reino de Aldor]
    I had no problem with Chrome
  • ZangarZangar Indianapolis
    my download asked for disk 2
  • You ran out of space on c drive trying to install it ? happened to mate, you need several gig free for it to run installer no matter where you install it.

    If its not that Id try clearing the download cache in chrome
  • I've downloaded with both programs and got the same result. Cleaning the download cache in chrome might work. I've got tons of space so it's not the memory.
  • Nope. No luck. Will keep trying to download it and see what happens.
  • Last one said unexpected end of archive. Vexing.
  • Ok problems solved useing a file download program. Must have been some hiccups in the downloads. That took... since Friday night actually. Ok if anyone else has this problem try downloading Free download manager or something like that. Thanks for the replies.
  • edited December 2018
    I am having the same problem. With Chrome it says checksum error when the install files are extracting. With Mozilla Firefox it says the resource file is corrupt during the install.
  • I am having the same issue. The file download program is not helping
  • edited December 2018
    Same here… Once 534 MB was downloaded (should be more I knew :-)), other try, the download ends without an error-message before the 3GB+ was done…
    But, after I used the "free-download-manager" (found by chip.de), set all on "max" an now it works fine… imageUrrgh, hope you understand what I mean = not my langue *g*
  • Any mods who can help us? We could'nt play all weekend. I disabled windows defender, deleted antivirus. But still get files are corrupt message after executing the patch file.(checksum error thing)
  • Is happening to me as well I would like to try this thing out was so excited after finding the game last night looks really good. I get the bin 1 or 2 or both error with or with out the manager.
  • SmokifiedSmokified United States
    Maxcorps said:

    When I try to download it from Edge it says the signature of LegendsOfAria-0.8.2.exe is corrupt or invalid.

    If there is a signature mismatch, you could all be downloading and installing a virus. It is pretty likely, even though Citadel doesn't realize it, their entire network is owned.
  • I did have a similar issue with 8.3 a few days back, for some reason that the launcher launched before the download was complete and it said the file was corrupt, download it again, just re-downloaded and made sure the full file downloaded and it was fine
  • LordDraedLordDraed United States
    Also having the same problem. I have redownloaded 10 times now and tried installing again each time but still get the same files are corrupt message and the checksum error. Have tried download manager and used both chrome and Firefox...any fixes?
  • edited January 24
    Try from direct link
    http://cdn2.legendsofaria.com/LegendsOfAria-0.8.3.exe

    If still issues maybe try and turn off Anti-virus. But I havent had any issues.
Sign In or Register to comment.