cant install

I have downloaded the client 3 times now and each time when i try to run it i get a message that the archive is corrupt and i should download the client again .Losing my patience with this.


  • SachaSacha [Reino de Aldor]
    Might be a problem with the operating system. You better write here the size or the download (so we can check if it's ok) and the specs of your system.
  • the download is 2.7gb and the os is win 10. Cpu an i7 ,16gb ram ,gpu nvidia 965 m(laptop card)
  • I see now that the download fails to complete .This last time at 60 odd % .This was the 8th or 9th attempt.My connection is good and all firewalls ,anti virus are disabled.When the download stops there is a message about the identity of the Publisher (or something ) could not be confirmed...translated from dutch.
  • SachaSacha [Reino de Aldor]
    there is an issue with the amazon download that happens only to some users.
    Maybe a friend can upload the game to a different location for you to download, or ask a nearby friend to downlowd it and give it to you in a usb pendrive or something...
  • Sorry I'm a bit late to this thread, but I was suffering exactly from this problem. I think I may have found a work-around for it.

    Instead of simply clicking on the download link I right-clicked it and selected 'save target as' and saved it like that. Running it the archive has extracted without a problem and I am able to proceed with installation. Hope this helps!
  • crunchnastycrunchnasty california
    Sooo im having a similar problem. When I try to run the client, it tells me the archive files are corrupt and I need to re download the exe file. I've done this like 5 times. Please help!
  • Same issue, multiple attempts, always get the corrupt files notice. This is my first and only experience with the game and it is very bad. Seeking a refund.
  • HiSkippyHiSkippy
    same here can't get in archive error???
  • @ ALL with same/similar problem - plz read this (posted by Citadel Studios) :

    ..most important is the mandatory email to the devs, also drop a comment here when it´s solved! ;)
  • edited April 2018
    Same problem here. I downloaded the program 5 times and the same problem occurs. I bought the game 10 days ago but couldn't play for multiples bugs...

    Anyone found a solution for this?
  • BelgeranBelgeran Australia
    If your internet connection is too unstable to download large files, Get a HTTP download manager.
    back in the 90's when i was on dialup i used "getright" i think it was called, threads your http downloads into multiple parts and allows resuming of failed downloads.

    The download is hosted on amazon AWS, so it is unlikely the issue is on their end as many 10000's of websites use AWS so their would be more complaining. Do make sure you havent ran any "speed up my internet" type programs that make registry tweaks, as non default TCP behavior can effect it, you could also try running your modem in bridge instead of NAT incase your hitting the same issue this guy did
  • Ok, the problem is solved. Someone from Citadel answered me by email. You have to download via this link:

    Then it's working for me! :)
  • I shared the link for 0.6.1 and was asked to remove the link since we are not supposed to share the download link in public spaces since we are technically still in closed beta. In that light, you may want to consider editing that post @Henri - just a heads up.
  • MentisMentis germany
    Hi @ all. Is the new client 0.6.3b suitable for 32-bit or 64-bit windows systems?
Sign In or Register to comment.